PDA

View Full Version : wildcard SSL certificate and WHM incompatible?!



jani83
05-16-2008, 15:57 PM
As tech support are going around in circles with this issue, I thought I'd see if anyone in forum-land can help me (and them).

Previously I ran a site on a Jag server running Plesk. There is the core site, and multiple subdomains. All required an SSL certificate, so I got a wildcard certificate. I installed it, they all ran off the one IP, and everything was fine for several months.

Recently we decided to migrate to another machine, this time running WHM/cPanel. Migration went smoothly until we try to re-install the wildcard certificate. It wouldn't work for any more than one subdomain. If it works for https://subdomain1.mydomain.com, for instance, then https://subdomain2.mydomain.com also points to subdomain1. Which isn't what we want. We are told we need to buy more IPs (which we hadn't needed before). So we buy them. Doesn't work. We are told we need to set up the subdomains as their own accounts. So we do. Doesn't work. This has been going on since Friday morning, our sites are down, and it is increasingly clear that tech support don't have a clue.

mafrussian
05-18-2008, 20:13 PM
You need plesk to make this work. Look it up in there documentation. It's way easier this way. Also if you run it without a cpanel its much faster.

james0131
01-29-2014, 02:54 AM
You need plesk to make this work. Look it up in there documentation. It's way easier this way. Also if you run it without a cpanel its much faster.


I agree with him i had try with my freind website this only it work great for me